re = /^\s*(?=(?:POST|GET|DELETE|PUT|PATCH|OPTIONS)\b)/m
str = ' edit_user_registration GET /users/edit(.:format) registrations#edit
PATCH /users(.:format) registrations#update'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end