using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<a.*? href=[^>]*><img.*? alt="")(""[^>]*></a>)";
string input = @"<a href=""something.com""><img src=""blah.jpg"" alt=""Game""></a>
<a href=""something.com""><img src=""blah.jpg"" alt=""></a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}