$re = '@(<a.*? href=[^>]*><img.*? alt=")("[^>]*></a>)@';
$str = '<a href="something.com"><img src="blah.jpg" alt="Game"></a>
<a href="something.com"><img src="blah.jpg" alt=""></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);