#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([a-z-]*[a-z_]+)([_A-Z0-9\.-]+)+(-[a-z_]+)?\.(jar|zip)"
Local $sString = "cdrf_irs-4.5.0-DEV_CDRF-4.5_RC3-SNAPSHOT-schema.zip"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")