// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-z-]*[a-z_]+)([_A-Z0-9\.-]+)+(-[a-z_]+)?\.(jar|zip)").unwrap();
let string = "cdrf_irs-4.5.0-DEV_CDRF-4.5_RC3-SNAPSHOT-schema.zip";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}