use strict;
my $str = 'cdrf_irs-4.5.0-DEV_CDRF-4.5_RC3-SNAPSHOT-schema.zip';
my $regex = qr/([a-z-]*[a-z_]+)([_A-Z0-9\.-]+)+(-[a-z_]+)?\.(jar|zip)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}