import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-z-]*[a-z_]+)([_A-Z0-9\\.-]+)+(-[a-z_]+)?\\.(jar|zip)";
final String string = "cdrf_irs-4.5.0-DEV_CDRF-4.5_RC3-SNAPSHOT-schema.zip";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}