#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*\b(Amazon|eBay|AliBaba)\b).*$"
Local $sString = "some vendor text before Amazon some after " & @CRLF & _
"some vendor text before eBay some after" & @CRLF & _
"some vendor text before AliBaba some after " & @CRLF & _
"some vendor text before Apple some after "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")