$re = '/^(?!.*\b(Amazon|eBay|AliBaba)\b).*$/m';
$str = 'some vendor text before Amazon some after
some vendor text before eBay some after
some vendor text before AliBaba some after
some vendor text before Apple some after ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);