re = /^(?!.*\b(Amazon|eBay|AliBaba)\b).*$/m
str = 'some vendor text before Amazon some after
some vendor text before eBay some after
some vendor text before AliBaba some after
some vendor text before Apple some after '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end