using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\b(Amazon|eBay|AliBaba)\b).*$";
string input = @"some vendor text before Amazon some after
some vendor text before eBay some after
some vendor text before AliBaba some after
some vendor text before Apple some after ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}