import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\b(Amazon|eBay|AliBaba)\\b).*$";
final String string = "some vendor text before Amazon some after \n"
+ "some vendor text before eBay some after\n"
+ "some vendor text before AliBaba some after \n"
+ "some vendor text before Apple some after ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}