using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\([0-9]{3}\) [0-9]{3}-[0-9]{4}$";
string input = @"(800) 867-5309
800 867-5309
(800)867-5309
1(800) 867-53090909090909";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}