$re = '/^\([0-9]{3}\) [0-9]{3}-[0-9]{4}$/m';
$str = '(800) 867-5309
800 867-5309
(800)867-5309
1(800) 867-53090909090909';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);