re = /^\([0-9]{3}\) [0-9]{3}-[0-9]{4}$/m
str = '(800) 867-5309
800 867-5309
(800)867-5309
1(800) 867-53090909090909'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end