// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\([0-9]{3}\) [0-9]{3}-[0-9]{4}$").unwrap();
let string = "(800) 867-5309
800 867-5309
(800)867-5309
1(800) 867-53090909090909";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}