package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\([0-9]{3}\) [0-9]{3}-[0-9]{4}$`)
var str = `(800) 867-5309
800 867-5309
(800)867-5309
1(800) 867-53090909090909`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}