#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\\\#\%\&\*\{\}\:\<\>\?\|\"\-\!]+$"
Local $sString = "/exemplo/arquivo/\Invalido.exe " & @CRLF & _
"/exemplo/arquivo/valido.xyz" & @CRLF & _
"/exem#plo/arquivo/Invalido.txt" & @CRLF & _
"/exemplo/arquivo/este_e_valido.xyzaa" & @CRLF & _
"/exemplo/arquivo/Inva%lido.txt" & @CRLF & _
"/exemplo/arquivo/tambem é valido.txt" & @CRLF & _
"/exemplo/arquivo/&Invalido.txt" & @CRLF & _
"/exemplo/arquivo/mais um valido.dat" & @CRLF & _
"/exemplo/arqui*vo/Invalido.txt" & @CRLF & _
"/exemplo/arquivo/aqui, valido tambem.txt" & @CRLF & _
"/ex{emplo/arquivo/Invalido.txt" & @CRLF & _
"/exemplo/arquivo/de novo valido.abc" & @CRLF & _
"/exemplo/arquivo/Invalido.txt}" & @CRLF & _
"/exemplo/arquivo/aqui, valido tambem.defg" & @CRLF & _
"/ex:emplo/arquivo/Invalido.txt" & @CRLF & _
"/exemplo/arquivo/valido com = .hij " & @CRLF & _
"/exe>>>>>>>mplo/arquivo/Invalido.txt" & @CRLF & _
"/exemplo/arquivo/valido tambem com ^.lm" & @CRLF & _
"/exemplo/arquivo/Invalido.<txt" & @CRLF & _
"/exemplo/arquivo/valido tambem.txt$$$$" & @CRLF & _
"/exemplo/arquiv>o/Invalido.txt" & @CRLF & _
"/exemplo/arquivo/@@@@valido@@@@@.n" & @CRLF & _
"?/exemplo/arquivo/Invalido.txt" & @CRLF & _
"/exemplo/arquivo/++++++++++++valido/////////.txt" & @CRLF & _
"/exemplo/arquivo/Invalido|.txt" & @CRLF & _
"/exemplo/arquivo/valido;;;;;;.opqqqqq" & @CRLF & _
"/exemplo/arquivo/"Invalido".txt" & @CRLF & _
"/exemplo/arquivo/valido.rst" & @CRLF & _
"/exemplo/-arquivo-/Invalido.txt" & @CRLF & _
"/exemplo/arquivo/valido_.uvwx" & @CRLF & _
"/exemplo/arquivo/Invalido!.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")