using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^\\\#\%\&\*\{\}\:\<\>\?\|\""\-\!]+$";
string input = @"/exemplo/arquivo/\Invalido.exe
/exemplo/arquivo/valido.xyz
/exem#plo/arquivo/Invalido.txt
/exemplo/arquivo/este_e_valido.xyzaa
/exemplo/arquivo/Inva%lido.txt
/exemplo/arquivo/tambem é valido.txt
/exemplo/arquivo/&Invalido.txt
/exemplo/arquivo/mais um valido.dat
/exemplo/arqui*vo/Invalido.txt
/exemplo/arquivo/aqui, valido tambem.txt
/ex{emplo/arquivo/Invalido.txt
/exemplo/arquivo/de novo valido.abc
/exemplo/arquivo/Invalido.txt}
/exemplo/arquivo/aqui, valido tambem.defg
/ex:emplo/arquivo/Invalido.txt
/exemplo/arquivo/valido com = .hij
/exe>>>>>>>mplo/arquivo/Invalido.txt
/exemplo/arquivo/valido tambem com ^.lm
/exemplo/arquivo/Invalido.<txt
/exemplo/arquivo/valido tambem.txt$$$$
/exemplo/arquiv>o/Invalido.txt
/exemplo/arquivo/@@@@valido@@@@@.n
?/exemplo/arquivo/Invalido.txt
/exemplo/arquivo/++++++++++++valido/////////.txt
/exemplo/arquivo/Invalido|.txt
/exemplo/arquivo/valido;;;;;;.opqqqqq
/exemplo/arquivo/""Invalido"".txt
/exemplo/arquivo/valido.rst
/exemplo/-arquivo-/Invalido.txt
/exemplo/arquivo/valido_.uvwx
/exemplo/arquivo/Invalido!.txt";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}