# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\\\#\%\&\*\{\}\:\<\>\?\|\"\-\!]+$"
test_str = ("/exemplo/arquivo/\\Invalido.exe \n"
"/exemplo/arquivo/valido.xyz\n"
"/exem#plo/arquivo/Invalido.txt\n"
"/exemplo/arquivo/este_e_valido.xyzaa\n"
"/exemplo/arquivo/Inva%lido.txt\n"
"/exemplo/arquivo/tambem é valido.txt\n"
"/exemplo/arquivo/&Invalido.txt\n"
"/exemplo/arquivo/mais um valido.dat\n"
"/exemplo/arqui*vo/Invalido.txt\n"
"/exemplo/arquivo/aqui, valido tambem.txt\n"
"/ex{emplo/arquivo/Invalido.txt\n"
"/exemplo/arquivo/de novo valido.abc\n"
"/exemplo/arquivo/Invalido.txt}\n"
"/exemplo/arquivo/aqui, valido tambem.defg\n"
"/ex:emplo/arquivo/Invalido.txt\n"
"/exemplo/arquivo/valido com = .hij \n"
"/exe>>>>>>>mplo/arquivo/Invalido.txt\n"
"/exemplo/arquivo/valido tambem com ^.lm\n"
"/exemplo/arquivo/Invalido.<txt\n"
"/exemplo/arquivo/valido tambem.txt$$$$\n"
"/exemplo/arquiv>o/Invalido.txt\n"
"/exemplo/arquivo/@@@@valido@@@@@.n\n"
"?/exemplo/arquivo/Invalido.txt\n"
"/exemplo/arquivo/++++++++++++valido/////////.txt\n"
"/exemplo/arquivo/Invalido|.txt\n"
"/exemplo/arquivo/valido;;;;;;.opqqqqq\n"
"/exemplo/arquivo/\"Invalido\".txt\n"
"/exemplo/arquivo/valido.rst\n"
"/exemplo/-arquivo-/Invalido.txt\n"
"/exemplo/arquivo/valido_.uvwx\n"
"/exemplo/arquivo/Invalido!.txt")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.