use strict;
my $str = '/exemplo/arquivo/\\Invalido.exe
/exemplo/arquivo/valido.xyz
/exem#plo/arquivo/Invalido.txt
/exemplo/arquivo/este_e_valido.xyzaa
/exemplo/arquivo/Inva%lido.txt
/exemplo/arquivo/tambem é valido.txt
/exemplo/arquivo/&Invalido.txt
/exemplo/arquivo/mais um valido.dat
/exemplo/arqui*vo/Invalido.txt
/exemplo/arquivo/aqui, valido tambem.txt
/ex{emplo/arquivo/Invalido.txt
/exemplo/arquivo/de novo valido.abc
/exemplo/arquivo/Invalido.txt}
/exemplo/arquivo/aqui, valido tambem.defg
/ex:emplo/arquivo/Invalido.txt
/exemplo/arquivo/valido com = .hij
/exe>>>>>>>mplo/arquivo/Invalido.txt
/exemplo/arquivo/valido tambem com ^.lm
/exemplo/arquivo/Invalido.<txt
/exemplo/arquivo/valido tambem.txt$$$$
/exemplo/arquiv>o/Invalido.txt
/exemplo/arquivo/@@@@valido@@@@@.n
?/exemplo/arquivo/Invalido.txt
/exemplo/arquivo/++++++++++++valido/////////.txt
/exemplo/arquivo/Invalido|.txt
/exemplo/arquivo/valido;;;;;;.opqqqqq
/exemplo/arquivo/"Invalido".txt
/exemplo/arquivo/valido.rst
/exemplo/-arquivo-/Invalido.txt
/exemplo/arquivo/valido_.uvwx
/exemplo/arquivo/Invalido!.txt';
my $regex = qr/^[^\\\#\%\&\*\{\}\:\<\>\?\|\"\-\!]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}