import Foundation
let pattern = ##"^[^\\\#\%\&\*\{\}\:\<\>\?\|\"\-\!]+$"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
/exemplo/arquivo/\Invalido.exe
/exemplo/arquivo/valido.xyz
/exem#plo/arquivo/Invalido.txt
/exemplo/arquivo/este_e_valido.xyzaa
/exemplo/arquivo/Inva%lido.txt
/exemplo/arquivo/tambem é valido.txt
/exemplo/arquivo/&Invalido.txt
/exemplo/arquivo/mais um valido.dat
/exemplo/arqui*vo/Invalido.txt
/exemplo/arquivo/aqui, valido tambem.txt
/ex{emplo/arquivo/Invalido.txt
/exemplo/arquivo/de novo valido.abc
/exemplo/arquivo/Invalido.txt}
/exemplo/arquivo/aqui, valido tambem.defg
/ex:emplo/arquivo/Invalido.txt
/exemplo/arquivo/valido com = .hij
/exe>>>>>>>mplo/arquivo/Invalido.txt
/exemplo/arquivo/valido tambem com ^.lm
/exemplo/arquivo/Invalido.<txt
/exemplo/arquivo/valido tambem.txt$$$$
/exemplo/arquiv>o/Invalido.txt
/exemplo/arquivo/@@@@valido@@@@@.n
?/exemplo/arquivo/Invalido.txt
/exemplo/arquivo/++++++++++++valido/////////.txt
/exemplo/arquivo/Invalido|.txt
/exemplo/arquivo/valido;;;;;;.opqqqqq
/exemplo/arquivo/"Invalido".txt
/exemplo/arquivo/valido.rst
/exemplo/-arquivo-/Invalido.txt
/exemplo/arquivo/valido_.uvwx
/exemplo/arquivo/Invalido!.txt
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)