using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http:\/\/((.+?)\/)+";
string input = @"http://www.reddit.com/r/programming/comments/15s4sv/finally_released_an_update_to_my_regular/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}