$re = '/http:\/\/((.+?)\/)+/';
$str = 'http://www.reddit.com/r/programming/comments/15s4sv/finally_released_an_update_to_my_regular/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);