const regex = /http:\/\/((.+?)\/)+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\\\/\\\/((.+?)\\\/)+', '')
const str = `http://www.reddit.com/r/programming/comments/15s4sv/finally_released_an_update_to_my_regular/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}