package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`http:\/\/((.+?)\/)+`)
var str = `http://www.reddit.com/r/programming/comments/15s4sv/finally_released_an_update_to_my_regular/`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}