re = /http:\/\/((.+?)\/)+/
str = 'http://www.reddit.com/r/programming/comments/15s4sv/finally_released_an_update_to_my_regular/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end