#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^{]*({[^}]*})"
Local $sString = "{" & @CRLF & _
" "foo":"main"," & @CRLF & _
" "baz":1," & @CRLF & _
" "obj":{" & @CRLF & _
" "T2":18," & @CRLF & _
" "H2":73," & @CRLF & _
" "T3":20," & @CRLF & _
" "H3":53" & @CRLF & _
" }," & @CRLF & _
" "bar":"side"," & @CRLF & _
" "when":"2000-01-01T00:00:50.500Z"" & @CRLF & _
"}..." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")