// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[^{]*({[^}]*})").unwrap();
let string = "{
\"foo\":\"main\",
\"baz\":1,
\"obj\":{
\"T2\":18,
\"H2\":73,
\"T3\":20,
\"H3\":53
},
\"bar\":\"side\",
\"when\":\"2000-01-01T00:00:50.500Z\"
}...
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}