import re
regex = re.compile(r"[^{]*({[^}]*})", flags=re.MULTILINE)
test_str = ("{\n"
" \"foo\":\"main\",\n"
" \"baz\":1,\n"
" \"obj\":{\n"
" \"T2\":18,\n"
" \"H2\":73,\n"
" \"T3\":20,\n"
" \"H3\":53\n"
" },\n"
" \"bar\":\"side\",\n"
" \"when\":\"2000-01-01T00:00:50.500Z\"\n"
"}...\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")