import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\{]*(\\{[^\\}]*\\})";
final String string = "{\n"
+ " \"foo\":\"main\",\n"
+ " \"baz\":1,\n"
+ " \"obj\":{\n"
+ " \"T2\":18,\n"
+ " \"H2\":73,\n"
+ " \"T3\":20,\n"
+ " \"H3\":53\n"
+ " },\n"
+ " \"bar\":\"side\",\n"
+ " \"when\":\"2000-01-01T00:00:50.500Z\"\n"
+ "}...\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}