const regex = /[^{]*({[^}]*})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^{]*({[^}]*})', 'gm')
const str = `{
"foo":"main",
"baz":1,
"obj":{
"T2":18,
"H2":73,
"T3":20,
"H3":53
},
"bar":"side",
"when":"2000-01-01T00:00:50.500Z"
}...
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}