const regex = /- - .* "GET .*\?do\=.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('- - .* "GET .*\\?do\\=.*', '')
const str = `- - [27/Sep/2013:12:41:21 +0200] "GET /shop/index.php?do=/blog/add HTTP/1.1" 301 566 "http://www.tld.com/shop/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1;)"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}