re = /- - .* "GET .*\?do\=.*/
str = '- - [27/Sep/2013:12:41:21 +0200] "GET /shop/index.php?do=/blog/add HTTP/1.1" 301 566 "http://www.tld.com/shop/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1;)"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end