import Foundation
let pattern = #"- - .* "GET .*\?do\=.*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"- - [27/Sep/2013:12:41:21 +0200] "GET /shop/index.php?do=/blog/add HTTP/1.1" 301 566 "http://www.tld.com/shop/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1;)""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}