// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"- - .* "GET .*\?do\=.*"#).unwrap();
let string = "- - [27/Sep/2013:12:41:21 +0200] \"GET /shop/index.php?do=/blog/add HTTP/1.1\" 301 566 \"http://www.tld.com/shop/\" \"Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1;)\"";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}