const regex = /^(?!-)\d{1,3}(?:,\d{3})*(?:\.\d{2})?$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!-)\\d{1,3}(?:,\\d{3})*(?:\\.\\d{2})?$', 'mg')
const str = `10,000`;
const subst = `\L`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);