$re = '/^(?!-)\d{1,3}(?:,\d{3})*(?:\.\d{2})?$/m';
$str = '10,000';
$subst = "\L";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;