import Foundation
let pattern = #"^(?!-)\d{1,3}(?:,\d{3})*(?:\.\d{2})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"10,000"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\L"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)