re = /^(?!-)\d{1,3}(?:,\d{3})*(?:\.\d{2})?$/m
str = '10,000'
subst = '\\L'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result