use strict;
my $str = '10,000';
my $regex = qr/^(?!-)\d{1,3}(?:,\d{3})*(?:\.\d{2})?$/mp;
my $subst = '\\L';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";