# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'\b([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{12})\b'/X'\4\3\2\1\6\5\8\7\9\10\11'/gm;t' <<< "'FE334797-0A46-468D-91F2-0005F1EC67EC'"