$re = '/\'\b([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{12})\b\'/m';
$str = '\'FE334797-0A46-468D-91F2-0005F1EC67EC\'';
$subst = "X'\4\3\2\1\6\5\8\7\9\10\11'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;