import Foundation
let pattern = #"'\b([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{12})\b'"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"'FE334797-0A46-468D-91F2-0005F1EC67EC'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"X'\4\3\2\1\6\5\8\7\9\10\11'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)