use strict;
my $str = '\'FE334797-0A46-468D-91F2-0005F1EC67EC\'';
my $regex = qr/'\b([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{12})\b'/mp;
my $subst = 'X\'\\4\\3\\2\\1\\6\\5\\8\\7\\9\\10\\11\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";