// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)'\b([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{2})([A-F0-9]{2})-([A-F0-9]{12})\b'").unwrap();
let string = "'FE334797-0A46-468D-91F2-0005F1EC67EC'";
let substitution = "X'\\4\\3\\2\\1\\6\\5\\8\\7\\9\\10\\11'";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}