#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)ORDER BY.*?(?=\s*LIMIT|\)|$)"
Local $sString = "SELECT * FROM table ORDER BY name" & @CRLF & _
"" & @CRLF & _
"SELECT a.* FROM (SELECT * FROM table ORDER BY name, created_at) AS a ORDER BY a.name" & @CRLF & _
"" & @CRLF & _
"SELECT t0.* FROM table t0 WHERE t0.created_at IS NOT NULL ORDER BY t0.name, t0.created_at, t0.status LIMIT 10 OFFSET 10"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)