# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"ORDER BY.*?(?=\s*LIMIT|\)|$)"
test_str = ("SELECT * FROM table ORDER BY name\n\n"
"SELECT a.* FROM (SELECT * FROM table ORDER BY name, created_at) AS a ORDER BY a.name\n\n"
"SELECT t0.* FROM table t0 WHERE t0.created_at IS NOT NULL ORDER BY t0.name, t0.created_at, t0.status LIMIT 10 OFFSET 10")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.