re = /ORDER BY.*?(?=\s*LIMIT|\)|$)/mi
str = 'SELECT * FROM table ORDER BY name
SELECT a.* FROM (SELECT * FROM table ORDER BY name, created_at) AS a ORDER BY a.name
SELECT t0.* FROM table t0 WHERE t0.created_at IS NOT NULL ORDER BY t0.name, t0.created_at, t0.status LIMIT 10 OFFSET 10'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result