using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ORDER BY.*?(?=\s*LIMIT|\)|$)";
string substitution = @"";
string input = @"SELECT * FROM table ORDER BY name
SELECT a.* FROM (SELECT * FROM table ORDER BY name, created_at) AS a ORDER BY a.name
SELECT t0.* FROM table t0 WHERE t0.created_at IS NOT NULL ORDER BY t0.name, t0.created_at, t0.status LIMIT 10 OFFSET 10";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}